Lably
Skip to content

Border Gateway Protocol

Protocol for communicating routing information on the Internet

  • 34 min read
  • 11 chapters

Related on Lably

Through Autonomous system (Internet), Internet and Router (computing)

BGP used for routing within an autonomous system is called Interior Border Gateway Protocol (iBGP). In contrast, the Internet application of the protocol is called Exterior Border Gateway Protocol (EBGP).

History

In January 1989, at the 12th IETF meeting in Austin, Texas, Yakov Rekhter, Len Bosack, and Kirk Lougheed sat down at a table to design what ultimately became the Border Gateway Protocol (BGP). The initial BGP design was recorded on two napkins, hence often referenced to as the “Two-Napkin Protocol”. The design on the napkins was expanded to three hand-written sheets of paper from which the first interoperable BGP implementation was quickly developed. A photocopy of these three sheets of paper now hangs on the wall of a routing protocol development area at Cisco Systems in Milpitas, California. In the same year, RFC 1105 was published, and the BGP protocol (in various forms) has been in use on the Internet since 1994.

Half a year after the initial publication, the protocol definition was changed in 1990 with the publication of RFC 1136. In October 1991, BGP version 3 was defined in RFC 1267, obsoleting the two earlier versions. In 1994, the current version (BGP4), was published as RFC 1654. Its definition was replaced in March 1995 by RFC 1771. In January 2006, RFC 4271 was published, which currently is the latest definition of BGP4 (although updated by many other RFCs).

RFC 4271 corrected errors, clarified ambiguities and updated the specification with common industry practices. The major enhancement of BGP4 was the support for Classless Inter-Domain Routing (CIDR) and use of route aggregation to decrease the size of routing tables. In its native form, the BGP4 protocol can only work with IPv4 addresses. Since the publication of RFC 2283 in 1998, routing information about a wide range of "address families" (IPv4, IPv6, IPX, etc.) can be carried. The 'Multiprotocol Extensions' have been updated in 2000 with RFC 2858 and finally in 2007 with RFC 4760. With these extensions, the protocol is also referred to as Multiprotocol BGP (MP-BGP).

Sign in to keep reading

10 more chapters are free with a Lably account.

More in Computing and communication