Lably
Skip to content

Request for Comments

Publication of the development and standards for the Internet

  • 11 min read
  • 5 chapters
Steve Crocker , the author of several Request for Comments documents, including the very first RFC.
Joi Ito · CC BY 2.0

Related on Lably

Through Internet, Memorandum and ARPANET

The IETF adopts some of the proposals published as RFCs as Internet Standards. However, many RFCs are informational or experimental in nature and are not standards. The RFC system was invented by Steve Crocker in 1969 to help record unofficial notes on the development of ARPANET. RFCs have since become official documents of Internet specifications, communications protocols, procedures, and events. According to Crocker, the documents "shape the Internet's inner workings and have played a significant role in its success," but are not widely known outside the community.

Outside of the Internet community, other documents also called requests for comments have been published, as in U.S. Federal government work, such as the National Highway Traffic Safety Administration, as well as various other places such as Rust and RedoxOS.

History

The inception of the RFC format occurred in 1969 as part of the seminal ARPANET project. Today, it is the official publication channel for the Internet Engineering Task Force (IETF), the Internet Architecture Board (IAB), and – to some extent – the global community of computer network researchers in general.

The authors of the first RFCs typewrote their work and circulated hard copies among the ARPA researchers. Unlike the modern RFCs, many of the early RFCs were actual Requests for Comments and were titled as such to avoid sounding too declarative and to encourage discussion. The RFC leaves questions open and is written in a less formal style. This less formal style is now typical of Internet Draft documents, the precursor step before being approved as an RFC.

In December 1969, researchers began distributing new RFCs via the newly operational ARPANET. RFC 1, titled "Host Software", was written by Steve Crocker of the University of California, Los Angeles (UCLA), and published on April 7, 1969. Although written by Steve Crocker, the RFC had emerged from an early working group discussion between Steve Crocker, Steve Carr, and Jeff Rulifson.

In RFC 3, which first defined the RFC series, Crocker started attributing the RFC series to the Network Working Group. Rather than being a formal committee, it was a loose association of researchers interested in the ARPANET project. In effect, it included anyone who wanted to join the meetings and discussions about the project.

Many of the subsequent RFCs of the 1970s also came from UCLA, because UCLA had one of the first Interface Message Processors (IMPs) on ARPANET. The Augmentation Research Center (ARC) at Stanford Research Institute, directed by Douglas Engelbart, is another of the first four ARPANET nodes and the source of early RFCs. The ARC became the first network information center (InterNIC), which was managed by Elizabeth J. Feinler to distribute the RFCs along with other network information.

On April Fools' Day 1978, RFC 748 was published as a parody of the TCP/IP documentation style. This resumed in 1989 with the publication of RFC 1097, which describes an option for telnet clients to display subliminal messages. Subsequent April Fools' Day RFCs have been published annually since then, notably RFC 2324, which describes the Hyper Text Coffee Pot Control Protocol and defines the HTTP 418 "I'm a teapot" status. Humorous RFCs date back to RFC 439, published in January 1973.

RFC Editor function

From 1969 until 1998, Jon Postel served as the RFC editor. On his death in 1998, his obituary was published as RFC 2468.

Following the expiration of the original ARPANET contract with the U.S. federal government, the Internet Society, acting on behalf of the IETF, contracted with the Networking Division of the University of Southern California (USC) Information Sciences Institute (ISI) to assume the editorship and publishing responsibilities under the direction of the IAB. Sandy Ginoza joined USC/ISI in 1999 to work on RFC editing, and Alice Hagens in 2005. Bob Braden took over the role of RFC project lead, while Joyce K. Reynolds continued to be part of the team until October 13, 2006.

In July 2007, streams of RFCs were defined so that the editing duties could be divided. IETF documents came from IETF working groups or submissions sponsored by an IETF area director from the Internet Engineering Steering Group. The IAB can publish its own documents. A research stream of documents comes from the Internet Research Task Force (IRTF), and an independent stream from other outside sources. A new model was proposed in 2008, refined, and published in August 2009, splitting the task into several roles, including the RFC Series Advisory Group (RSAG). The model was updated in 2012,, and 2020. The streams were also refined in December 2009, with standards defined for their style. In January 2010, the RFC Editor function was moved to a contractor, Association Management Solutions, with Glenn Kowack serving as interim series editor. In late 2011, Heather Flanagan was hired as the permanent RFC Series Editor (RSE). Also at that time, an RFC Series Oversight Committee (RSOC) was created.

In 2020, the IAB convened the RFC Editor Future Development program to discuss potential changes to the RFC Editor model. The results of the program were included the RFC Editor Model (Version 3) as defined in RFC 9280, published in June 2022. Generally, the new model is intended to clarify responsibilities and processes for defining and implementing policies related to the RFC series and the RFC Editor function. Changes in the new model included establishing the position of the RFC Consulting Editor, the RFC Series Working Group (RSWG), and the RFC Series Approval Board (RSAB). It also established a new Editorial Stream for the RFC Series and concluded the RSOC. The role of the RSE was changed to the RFC Series Consulting Editor (RSCE). In September 2022, Alexis Rossi was appointed to that position.

New publishing format

Requests for Comments were originally produced in non-reflowable text format. In August 2019, the format was changed so that new documents can be viewed optimally in devices with varying display sizes.

Sign in to keep reading

4 more chapters are free with a Lably account.

More in Computing and communication