Lably
Skip to content

Kerberos (protocol)

Computer authentication protocol

  • 9 min read
  • 5 chapters

Related on Lably

Through Computer network, Computer security and Google

Kerberos builds on symmetric-key cryptography and requires a trusted third party, and optionally may use public-key cryptography during certain phases of authentication. Kerberos uses UDP port 88 by default.

The protocol was named after the character Cerberus, also spelled Kerberos, from Greek mythology, the ferocious three-headed guard dog of Hades.

History and development

The Massachusetts Institute of Technology (MIT) developed Kerberos in 1986 to protect network services provided by Project Athena. Its first version was primarily designed by Steve Miller and Clifford Neuman based on the earlier Needham–Schroeder symmetric-key protocol. Kerberos versions 1 through 3 were experimental and not released outside of MIT.

Kerberos version 4, the first public version, was released on January 24, 1989. Since Kerberos 4 was developed in the United States, and since it used the Data Encryption Standard (DES) encryption algorithm, U.S. export control restrictions prevented it from being exported to other countries. MIT created an exportable version of Kerberos 4 with all encryption code removed, called "Bones". Eric Young of Australia's Bond University reimplemented DES into Bones, in a version called "eBones", which could be freely used in any country. Sweden's Royal Institute of Technology released another reimplementation called KTH-KRB.

Neuman and John Kohl published version 5 in 1993 with the intention of overcoming existing limitations and security problems. Version 5 appeared as RFC 1510, which was then made obsolete by RFC 4120 in 2005.

In 2005, the Internet Engineering Task Force (IETF) Kerberos working group updated specifications. Updates included:

  • Encryption and Checksum Specifications (RFC 3961).
  • Advanced Encryption Standard (AES) Encryption for Kerberos 5 (RFC 3962).
  • A new edition of the Kerberos V5 specification "The Kerberos Network Authentication Service (V5)" (RFC 4120). This version obsoletes RFC 1510, clarifies aspects of the protocol and intended use in a more detailed and clearer explanation.
  • A new edition of the Generic Security Services Application Program Interface (GSS-API) specification "The Kerberos Version 5 Generic Security Service Application Program Interface (GSS-API) Mechanism: Version 2" (RFC 4121).

MIT makes an implementation of Kerberos freely available, under copyright permissions similar to those used for BSD. In 2007, MIT formed the Kerberos Consortium to foster continued development. Founding sponsors include vendors such as Oracle, Apple Inc., Google, Microsoft, Centrify Corporation and TeamF1 Inc., and academic institutions such as the Royal Institute of Technology in Sweden, Stanford University, MIT, and vendors such as CyberSafe offering commercially supported versions.

Sign in to keep reading

4 more chapters are free with a Lably account.

More in Computing and communication