Lably
Skip to content

Link layer

Lowest abstraction layer in the Internet protocol suite

  • 4 min read
  • 4 chapters

Related on Lably

Through Computer network, Internet protocol suite and Internet

Despite the different semantics of layering between the Internet protocol suite and OSI model, the link layer is sometimes described as a combination of the OSI's data link layer (layer 2) and physical layer (layer 1).

The link layer is described in RFC 1122 and RFC 1123. RFC 1122 considers local area network protocols such as Ethernet and other IEEE 802 networks (e.g. Wi-Fi), and framing protocols such as Point-to-Point Protocol (PPP) to belong to the link layer.

Definition in standards and textbooks

Local area networking standards such as Ethernet and IEEE 802.3 specifications use terminology from the seven-layer OSI model rather than the TCP/IP model. The TCP/IP model, in general, does not consider physical specifications; rather, it assumes a working network infrastructure that can deliver media-level frames on the link. Therefore, RFC 1122 and RFC 1123, the definition of the TCP/IP model, do not discuss hardware issues and physical data transmission and set no standards for those aspects. Some textbook authors have supported the interpretation that physical data transmission aspects are part of the link layer. Others assumed that physical data transmission standards are not considered communication protocols, and are not part of the TCP/IP model. These authors assume a hardware layer or physical layer below the link layer, and several of them adopt the OSI term data link layer instead of link layer in a modified description of layering. In the predecessor to the TCP/IP model, the ARPAnet Reference Model (RFC 908, 1982), aspects of the link layer are referred to by several poorly defined terms, such as network-access layer, network-access protocol, as well as network layer, while the next higher layer is called internetwork layer. In some modern textbooks, network-interface layer, host-to-network layer and network-access layer occur as synonyms either to the link layer or the data link layer, often including the physical layer.

Sign in to keep reading

3 more chapters are free with a Lably account.

More in Computing and communication