Lably
Skip to content

OAuth

Method of user authentication in computing

  • 9 min read
  • 6 chapters

Related on Lably

Through Amazon (company), Google and Client (computing)

Generally, the oAuth protocol provides a way for resource owners to provide a client application with secure delegated access to server resources, it specifies a process for resource owners to authorize third-party access to their server resources without providing credentials. Designed specifically to work with Hypertext Transfer Protocol (HTTP), oAuth essentially allows access tokens to be issued to third-party clients by an authorization server, with the approval of the resource owner. The third party then uses the access token to access the protected resources hosted by the resource server.

History

oAuth began in November 2006 when Blaine Cook was developing an OpenID implementation for Twitter. Meanwhile, Larry Halff of site Ma.gnolia needed a solution to allow its members with OpenIDs to authorize Mac OS X Dashboard widgets to access their service. Cook, Chris Messina and Larry Halff from Magnolia met with David Recordon to discuss using OpenID with the Twitter and Magnolia APIs to delegate authentication. They concluded that there were no open standards or APIs for access management.

The oAuth implementer group was created in April 2007, for to write the draft proposal for an open protocol. DeWitt Clinton, from Google, learned of this project and wanted to support the initiative. In July 2007, the team drafted the initial specification. Eran Hammer joined the group and coordinated various contributions to oAuth, resulting in a more formal specification. On October 3, 2007, oAuth Core 1.0 was released.

In November 2008, at the 73rd Internet Engineering Task Force (IETF) meeting, in Minneapolis, an oAuth BoF for include the protocol into the IETF for standardization work. There was wide support for chartering an working group within the IETF.

The oAuth 1.0 protocol was published as RFC 5849, an informational Request for Comments, in April 2010. Since 31 August 2010, all third party Twitter applications have been required to use oAuth. An RFC (Request for Comments) is an IETF document regarding Internet communication protocols.

The oAuth 2.0 framework was published considering additional use cases and extensibility requirements gathered from the wider IETF community. Albeit being built on the oAuth 1.0 deployment experience, oAuth 2.0 is not backwards compatible with oAuth 1.0. oAuth 2.0 was published as RFC 6749, and the RFC 6750 defines how version 2 uses access tokens, both standards track Requests for Comments, in October 2012.

As of November 2024, the oAuth 2.1 Authorization Framework draft is a work in progress. It consolidates the functionality in RFCs oAuth 2.0, oAuth 2.0 for Native Apps, Proof Key for Code Exchange, oAuth 2.0 for Browser-Based Apps, oAuth Security Best Current, and Bearer Token Usage.

Sign in to keep reading

5 more chapters are free with a Lably account.

More in Computing and communication