Lably
Skip to content

File Transfer Protocol

Standard protocol for transferring files over TCP/IP networks

  • 14 min read
  • 8 chapters

Learn it on Lably

The first FTP client applications were command-line programs developed before operating systems had graphical user interfaces, and are still shipped with most Windows and Unix-like operating systems. Many dedicated FTP clients and automation utilities have since been developed for desktops, servers, mobile devices, and hardware, and FTP has been incorporated into productivity applications such as HTML editors and file managers.

An FTP client used to be commonly integrated in web browsers, where file servers are browsed with the URI scheme "ftp://". In 2021, FTP support was dropped by Google Chrome and Firefox, two major web browser vendors, due to it being superseded by the more secure SFTP and FTPS; although neither browser has implemented the newer protocols.

History of FTP servers

The original specification for the File Transfer Protocol was written by Abhay Bhushan and published as RFC 114 on 16 April 1971. Until 1980, FTP ran on NCP, the predecessor of TCP/IP. The protocol was later replaced by a TCP/IP version, RFC 765 (June 1980) and RFC 959 (October 1985), the current specification. Several proposed standards amend RFC 959, for example RFC 1579 (February 1994) enables Firewall-Friendly FTP (passive mode), RFC 2228 (June 1997) proposes security extensions, RFC 2428 (September 1998) adds support for IPv6 and defines a new type of passive mode.

Sign in to keep reading

7 more chapters are free with a Lably account.

More in Computing and communication